We are investigating some performance issues with Batch Messaging loading sent messages
Incident Report for Accurx
Resolved
We are now seeing functionality return to normal.

Thank you for your patience and understanding while we worked on this issue. We'll investigate the root cause of this issue to prevent it from happening again.

If you're still having any trouble please reach out to our support team at support@accurx.com or chat to us at https://support.accurx.com/en/
Posted Feb 09, 2024 - 15:57 UTC
Investigating
We are seeing issues with loading sent Batch Messages. We're currently investigating the issue, and will provide an update soon.
Posted Feb 09, 2024 - 14:35 UTC
This incident affected: Accurx Desktop Services.