Intercom messenger down
Incident Report for Accurx
Resolved
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Oct 21, 2024 - 10:33 UTC
Investigating
Hi all, we're experiencing some technical issues with our live chat function this morning. If you require support, please email the team at support@accurx.com or have a browse our support articles: https://support.accurx.com/en/

Apologies for the inconvenience!
Posted Oct 21, 2024 - 10:25 UTC