Issues with attaching documents from EMIS
Incident Report for Accurx
Resolved
We think the impact from the issue is over.
Posted Apr 22, 2024 - 12:17 UTC
Investigating
We've spotted some issues with attaching documents from EMIS. We're currently investigating the issue, and will provide an update soon.
Posted Apr 22, 2024 - 09:37 UTC
This incident affected: Accurx Desktop Services.