We are investigating some performance issues with Batch Messaging
Incident Report for Accurx
Resolved
This issue has been resolved.

Thank you for your patience and understanding while we worked on this issue. We'll investigate the root cause of this issue to prevent it from happening again.

If you're still having any trouble please reach out to our support team at support@accurx.com or chat to us at https://support.accurx.com/en/
Posted Feb 07, 2024 - 16:56 UTC
Investigating
We've spotted some issues uploading CSV's to Batch Messaging + Batch Messages sending. We're currently investigating the issue, and will provide an update soon.
Posted Feb 07, 2024 - 16:15 UTC
This incident affected: Accurx Desktop Services.