Reports of slowness
Incident Report for Accurx
Resolved
We're investigating the issue.
Posted Oct 17, 2024 - 10:24 UTC
Identified
We have received report of an issue from Emis that could be causing some slowness with your toolbar. Emis is currently investigating this issue, we will update you as soon as we can.
Posted Oct 17, 2024 - 09:37 UTC
This incident affected: Accurx Desktop Services.