Issues with raising support queries
Incident Report for Accurx
Resolved
This should be resolved now, we're very sorry for any inconvenience this may have caused.
Posted May 07, 2024 - 16:08 UTC
Investigating
We've spotted that something has gone wrong with the service we use to answer your help queries. We're currently investigating the issue, and will provide an update soon.
Posted May 07, 2024 - 15:08 UTC
This incident affected: Accurx Help Center.