Accurx Slowness
Incident Report for Accurx
Resolved
We've now seen that products are returning to normal speeds. Sorry again for any inconvenience caused!
Posted Apr 29, 2024 - 13:39 UTC
Investigating
We're seeing that some of our products are running slower than expected. We're investigating the issue and hopefully have everything back up and running at normal speeds soon. Sorry for any inconvenience caused!
Posted Apr 29, 2024 - 11:08 UTC
This incident affected: Accurx Desktop Services.