We've received reports that notes are now being generated within Scribe. If you experienced issues, please try refreshing your page, and the note should regenerate.
Thank you for your patience and we apologise for any inconvenience caused.
If you are continuing to experience any problems, please reach out to our Support Team by clicking here or by emailing support@accurx.com
Resolved
We've received reports that notes are now being generated within Scribe. If you experienced issues, please try refreshing your page, and the note should regenerate.
Thank you for your patience and we apologise for any inconvenience caused.
If you are continuing to experience any problems, please reach out to our Support Team by clicking here or by emailing support@accurx.com
Identified
We have identified an issue with Scribe Note Generation and are working towards a resolution.
During this time we recommend that users refresh their page.
Next Update Due: 30 Minutes